----->>>>

flutter로 개발한 앱을 플레이스토어에 올릴때 API 레벨이 맞지 않다고 나올 경우…

IT 등/Flutter 2020. 9. 20. 22:53

최근, flutter에 관심이 있어서 간단한 앱을 끄적이고 있었다.

AVD로 테스트 하고서 배포 테스트를 하려니 플레이스토어 계정도 파야 했었다. 25$ 들었고…

그런데 개발하는 것보다 플레이스토어 콘솔 사용법이 더 어려웠다. 또 UI는 왜 바꾸는지…

인터넷에 있는 모든 자료는 구버전 UI 기준인데 새로 바꾼 UI에서는 그 내용을 찾을 수 없었다.

무엇보다, flutter로 앱 빌드했을때 targetSDK 버전이 기본적으로 28로 되어 있어서 아무런 수정 없이 업로드하면 안드로이드 API 수준이 맞지 않는다고 나온다(정확한 오류메시지는 기억 불가)

안드로이드 API를 29 이상으로 올려야 하는데, 인터넷을 아무리 검색해도 안드로이드 스튜디오에 관한 얘기만 있을뿐, 내가 쓰는 IntelliJ에 관한 얘기는 없다.

pycharm을 쓰며 그 인터페이스에 익숙해 있어서 인텔리제이를 골랐는데 이럴때는 더 힘드네.

결국 해결책을 찾았는데, 그 프로젝트의 android\app 디렉토리에 build.gradle 파일이 있는데 그 내용 중 android { } 패러그래프 안쪽의 compile SDK 버전과 targetSDK 버전을 29로 바꿔주고 다시 build를 수행하면 된다.

 

설정

트랙백

댓글