net::ERR_CACHE_MISS 에러

IT 등/Flutter 2020. 10. 6. 13:03

거 참, 팔자에 없는 앱개발을 해 보다보니 별 에러를 다 만난다.

이런거.



웹뷰를 쓰는 간단한 어플을 만들었는데, 실기기를 쓰지 않고 에뮬레이터로만 테스트 하다가 플레이스토어에 올렸더니 별 희안한 에러가 난다.

웹뷰를 쓰는데 인터넷 권한을 주지 않았다는거지.

흠, 플러터는 인터넷 권한은 기본으로 들어간다던데…

그래서 AndroidManifest.xml 파일에 권한 추가하는 명령어는 넣어줬다.

<uses-permission android:name="android.permission.INTERNET" />

설정

트랙백

댓글

안드로이드 apk, appbundle 버전 올리기

IT 등/Flutter 2020. 10. 2. 17:38

요새 flutter로 앱 만드는데 한참 재미붙이고 있는데, java가 아니고, Android Studio가 아닌 마이너한 방법을 쓰다보니 문서화가 약해서 참 어렵다. (그나마 더 마이너한 RAD Studio를 썼으면 얼마나 더 어려웠을꼬...)

플레이스토어 개발자 등록을 해 두고 테스트 앱을 올리고 있는데, 앱번들을 한번 올렸더니 "이미 버전 코드가 1인 APK 또는 Android App Bundle이 있으므로 다른 버전 코드를 사용해야 합니다." 라는 에러를 내며 등록이 안된다.

 

동일 버전의 apk나 appbundle을 업로드하면 나는 에러

 

머리를 좀 굴린답시고 build.gradle을 봤더니 거기 버전코드가 있었다.

하지만, 그건 변수로 받아올 값이 없을 때 얘기고, local.properties를 참조하는 것 같았다.

local.properties를 고쳤지만 이상하게 고쳐도..고쳐도 다시 원복된다. 뭔가 이상해.

늘 그렇듯이 답은 스택오버플로우에 있었다.

stackoverflow.com/questions/53570575/flutter-upgrade-the-version-code-for-play-store

Flutter: upgrade the version code for play store

i have published an application on the play store with flutter, now i want to upload a new version of the application. I am trying to change the version code with: flutter build apk --build-nam...

stackoverflow.com

딴데 손대지 말고 pubspec.yaml 파일을 고치면 된단다. 그 파일에 있는 version: 1.0.0 에 숫자를 더해주면 된다.

 

 

덧. 예전에 코딩할때는 전체를 다 암기했는데, 이제는 이런 설정사항 하나까지 다 블로그에 기록해놔야 하다니... 한편으로는 서글프네.

설정

트랙백

댓글

flutter로 개발한 앱을 플레이스토어에 올릴때 API 레벨이 맞지 않다고 나올 경우…

IT 등/Flutter 2020. 9. 20. 22:53

최근, flutter에 관심이 있어서 간단한 앱을 끄적이고 있었다.

AVD로 테스트 하고서 배포 테스트를 하려니 플레이스토어 계정도 파야 했었다. 25$ 들었고…

그런데 개발하는 것보다 플레이스토어 콘솔 사용법이 더 어려웠다. 또 UI는 왜 바꾸는지…

인터넷에 있는 모든 자료는 구버전 UI 기준인데 새로 바꾼 UI에서는 그 내용을 찾을 수 없었다.

무엇보다, flutter로 앱 빌드했을때 targetSDK 버전이 기본적으로 28로 되어 있어서 아무런 수정 없이 업로드하면 안드로이드 API 수준이 맞지 않는다고 나온다(정확한 오류메시지는 기억 불가)

안드로이드 API를 29 이상으로 올려야 하는데, 인터넷을 아무리 검색해도 안드로이드 스튜디오에 관한 얘기만 있을뿐, 내가 쓰는 IntelliJ에 관한 얘기는 없다.

pycharm을 쓰며 그 인터페이스에 익숙해 있어서 인텔리제이를 골랐는데 이럴때는 더 힘드네.

결국 해결책을 찾았는데, 그 프로젝트의 android\app 디렉토리에 build.gradle 파일이 있는데 그 내용 중 android { } 패러그래프 안쪽의 compile SDK 버전과 targetSDK 버전을 29로 바꿔주고 다시 build를 수행하면 된다.

 

설정

트랙백

댓글